© 2022 CyberNews - Latest tech news,
product reviews, and analyses.

If you purchase via links on our site, we may receive affiliate commissions.

How to set up NordVPN on your router


Using NordVPN is already a great way to ensure security and privacy online, but setting it up on a router is even better. You will be able to make use of such advantages as unlimited simultaneous connections, a VPN connection even on unsupported devices, and network-wide protection.

However, not all routers work with NordVPN or offer user-friendly configuration. The provider is only compatible with routers that support the OpenVPN protocol. Also, each router might simply have different configuration processes.

In this article, we’re going to walk you through all the steps on how to set up NordVPN on your router and make the setup process smooth and easy. Let’s jump right in.

NordVPN supported routers

When picking a router to set up NordVPN with, you can either choose a pre-configured one or set it up yourself. However, if you choose the latter option, you have to make sure that your router is compatible with NordVPN.

The VPN provider only works with routers that support the OpenVPN protocol. To find out if your router does, you can either check with the manufacturer or simply log into the router and have a look at the VPN settings. Here are some of the recommended routers to use with NordVPN:

ManufacturerRouter
AsusRT-AX86U, RT-AX88U (AX6000), RT-AC5300, RT-AC66U B1, RT-AC86U, Asus RT-AX3000
D-Link* DIR-885L, DIR-895L
Linksys* EA8500, WRT1900ACS, WRT3200ACM
Netgear*R7500, R7800, R8500, R9000

*Requires flashing with DD-WRT

These routers are great in terms of both performance and security and do not have high-performance setup requirements. While Asus is the recommended router that ensures the easiest setup process, other routers will do the job as well.

How to set up NordVPN on your router

Although installing a VPN on a router is a similar process for many router manufacturers, there are certain differences to be aware of. To make things easier for you, we’ll guide you through the process of setting up NordVPN on different routers.

The first steps of setting up NordVPN on a router will look similar to this:

  1. Download configuration files. For this, you will need to find the server that works best and download available protocols. You can find the best server for you here.
  2. Find your router’s IP address. Typically, the IP address is on the back or bottom of your router. It will look something like, for example, this: 192.168.1.1.
  3. Type your IP address into the browser's URL slot. You'll need to type in your password, which is located right next to the router's IP address. If you changed your password manually, type it in.

From here, the setup process will differ depending on routers, supported firmware, and other factors.

How to set up NordVPN with ASUS

For the simplest configuration process, ASUS routers are recommended to use with NordVPN. All you have to do is follow these simple steps:

  1. After logging into your router’s control panel, locate the “VPN” section and select the “VPN Client” tab on the side menu. Click on “Add profile."
Asus VPN section client tab 1
  1. In the opened window, select “OpenVPN” and fill in the fields. Type in any description you want. As for username and password, insert your NordVPN account details.
OpenVPN description account details tab 2
  1. Open the downloaded configuration file – click on the “Choose File” button, select the configuration file, and click “Open."
  2. Click “Upload” and wait for confirmation that the upload was successful.
  3. Leave the tick box “Import the CA file” unchecked and click “OK.”
upload configuration file confirmation 1
  1. In the “VPN Client” tab, you should see an option to “Activate” the connection. Go ahead and connect.
VPN client activation tab 1

A blue checkmark indicates that you are connected. That’s it!

How to set up NordVPN with DD-WRT

While the configuration process of DD-WRT may seem overwhelming, no worries! Follow this step-by-step guide and you’ll have it up and running in no time:

  1. In the Administrative Interface, navigate to “Setup”, then click on “Basic Setup.” In the section “Network Address Server Settings (DHCP),” set these NordVPN DNS addresses:
  • Static DNS 1: 103.86.96.100
  • Static DNS 2: 103.86.99.100
  • Static DNS 3: 0.0.0.0 (default)
  • Use DNSMasq for DHCP: Checked
  • Use DNSMasq for DNS: Checked
  • DHCP-Authoritative: Checked
administrative interface basic setup tab 2
  1. Click “Apply Settings” and “Save.”
  2. Navigate to the “Setup” tab, then locate the “IPv6” tab, and disable the IPv6 protocol. Click “Apply Settings” and “Save.“
IPv6 protocal disable tab 1
  1. Go to "Setup," then VPN. In the “OpenVPN Client” section, set “Start OpenVPN Client” to “Enable.” Set the following settings like this:
  • Server IP/Name: (The server you chose earlier from NordVPN recommended servers)
  • Port: 1194 (or 443 for the TCP protocol)
  • Tunnel Device: TUN
  • Tunnel Protocol: UDP (or TCP)
  • Encryption Cipher: AES-256-CBC
  • Hash Algorithm: SHA-512
  • User Pass Authentication: Enable
  • Username, Password: Your NordVPN service credentials (You’ll find them in NordVPN Account Dashboard)
  • First Data Cipher: Not set
  • Second Data Cipher: Not set
  • Third Data Cipher: Not set
  • Advanced Options: Enabled (3 additional options will appear)
  • TLS Cipher: None
  • LZO Compression: Disable
  • NAT: Enable
open vpn client settings 3
  1. In the Additional Config box, copy and paste these commands:

remote-cert-tls server
remote-random
nobind
tun-mtu 1500
tun-mtu-extra 32
mssfix 1450
persist-key
persist-tun
ping-timer-rem
reneg-sec 0
#log /tmp/vpn.log

  1. Open the downloaded configuration file in any text editor (preferably WordPad or Notepad++). After opening it, you should see the part of the file.
configuration file 1
  1. Copy the content of the command from the beginning till the end of the certificate and paste it into the “CA Cert” field.
  2. Go back to the configuration file and scroll down until you find the part. Copy its contents (without copying and ) and paste it into the TLS Auth Key field.
configuration file contents tls auth key field 4
  1. After pasting, click on “Apply Settings” and “Save.
  2. Verify the successful connection by navigating to “Status,” then “OpenVPN” and look for “Client: Connected Success.”
DD-wrt verify connection success 1

How to set up NordVPN with OpenWRT

The process of setting up NordVPN with OpenWRT is very straightforward. Here’s how to do it:

  1. The OpenWRT firmware will only support the telnet protocol, so you should connect to it with the IP address: 192.168.1.1. Change the root password with the command “passwd”. Then, the router will accept an SSH connection. After that, you need to install:
  • opkg update
  • opkg install openvpn-openssl
  • opkg install ip-full
  1. The OpenVPN configuration for NordVPN will ask you to input the username and password every time OpenVPN starts. To provide credentials automatically, attach the word "secret" with a preceding space to the string auth-user-pass. The resulting string should be auth-user-pass secret.
  2. Create a file with the name "secret" in the same folder and enter the credentials in it. The first line is your NordVPN service username, and the second is your NordVPN service password.
  3. Configuring OpenVPN using the configuration file could be done in two ways:
  • Change the file’s extension from .ovpn to .conf, which will allow OpenVPN to find it automatically by the extension.
  • Specify the file name in /etc/config/openvpn. You can use uci:

uci set openvpn.nordvpn=openvpn
uci set openvpn.nordvpn.enabled='1'
uci set openvpn.nordvpn.config='/etc/openvpn/al1.nordvpn.com.tcp.ovpn'
uci commit openvpn

The file /etc/config/openvpn should consist of the following attached strings:

config openvpn 'nordvpn'
option enabled '1'
option config '/etc/openvpn/al1.nordvpn.com.tcp.ovpn'

  1. You can also change the file’s extension from .ovpn to .conf and specify it in the file /etc/config/openvpn. In this case, OpenVPN will start with this configuration file just once.
  2. Create a new network interface. Have in mind that these are 2 different ways to do it, and it is recommended to use both at the same time. The recommended interface method:

uci set network.nordvpntun=interface
uci set network.nordvpntun.proto='none'
uci set network.nordvpntun.ifname='tun0'
uci commit network

The file /etc/config/network should consist of the following appended strings:

config interface 'nordvpntun'
option proto 'none'
option ifname 'tun0'

  1. Create a new firewall zone and add a forwarding rule from LAN to VPN:

uci add firewall zone
uci set [email protected][-1].name='vpnfirewall'
uci set [email protected][-1].input='REJECT'
uci set [email protected][-1].output='ACCEPT'
uci set [email protected][-1].forward='REJECT'
uci set [email protected][-1].masq='1'
uci set [email protected][-1].mtu_fix='1'
uci add_list [email protected][-1].network='nordvpntun'
uci add firewall forwarding
uci set [email protected][-1].src='lan'
uci set [email protected][-1].dest='vpnfirewall'
uci commit firewall

The file /etc/config/firewall should contain the following appended strings:

config zone
option name 'vpnfirewall'
option input 'REJECT'
option output 'ACCEPT'
option forward 'REJECT'
option masq '1'
option mtu_fix '1'
list network 'nordvpntun'
config forwarding
option src 'lan'
option dest 'vpnfirewall'

  1. Configure the DNS servers. The easiest way to do it is to use NordVPN DNS for the WAN interface of the router. Here’s how to add NordVPN DNS:

uci set network.wan.peerdns='0'
uci del network.wan.dns
uci add_list network.wan.dns='103.86.96.100'
uci add_list network.wan.dns='103.86.99.100'
uci commit

The file /etc/config/network should contain the section 'wan' with the following attachments (the three bottom strings have been appended):

config interface 'wan'
option ifname 'eth0.2'
option force_link '1'
option proto 'dhcp'
option peerdns '0'
list dns '103.86.96.100'
list dns '103.86.99.100'

Everything should be configured and you should be connected successfully when you finish these instructions. Go to NordVPN’s homepage and look for Protected status at the top to check.

If you need to set up NordVPN with other manufacturers, check out other setup guides for supported routers and firmware.

Why should I use NordVPN on my router?

You might be wondering what are the benefits of using NordVPN on your router. We have outlined some of the top perks below:

  • Unlimited simultaneous connections. NordVPN limits simultaneous connections to 6 devices only when connecting devices one at a time. When you use NordVPN on a router, all of the devices on the network are protected.
  • Using a VPN on unsupported devices. Even devices that don't support VPN services are protected when you set up a VPN on a router. This is useful when you want to bypass geo-restrictions on streaming devices that don’t allow a VPN connection.
  • Security. You can forget turning the VPN connection on and off on each device manually. When a user connects to a device through a router, traffic becomes automatically encrypted on all devices.

Routers not compatible with NordVPN

It is important to know that not all routers are compatible with NordVPN. That is because the provider’s servers stopped supporting L2TP/IPsec and PPTP connections and only work with OpenVPN. You won’t be able to use NordVPN with any of the routers with their native firmware listed below:

  • Arris
  • Belkin
  • Cisco
  • D-Link
  • Huawei
  • Linksys (except WRT32X/WRT32XB AC3200)
  • Netgear
  • TP-Link
  • TRENDnet
  • Tenda
  • TotoLink
  • Ubee
  • Most ISP-provided routers that were mentioned above

If you’re not sure whether your router is supported, take a look at the NordVPN supported routers that we provided.

NordVPN not working with a router? Here's how to fix it:

If you're having trouble setting up a VPN on your router, it's because the router lacks the necessary firmware to support VPN. This method of setting up a VPN is not supported by most routers. There are two ways to fix this:

  1. Get a new router. In this case, the simplest solution is to purchase a new router that meets the requirements for setting up a VPN.
  2. Download custom firmware. It is also possible to download custom firmware on supported routers to set up NordVPN manually. Some of them include DD-WRT, Tomato, Padavan, and OpenWRT.

However, if you're still having issues after successfully setting up your router with NordVPN, it could be one of these causes:

  • Internet connection. Make sure that there are no problems with your Internet connection.
  • Router is not reset. To refresh the router’s configuration and solve errors, turn the router off and turn it back on in a few minutes. Keep in mind that this will not reset NordVPN settings.
  • Router is not up to date. It's also possible that you’re using an older version of the router, so check for new updates.
  • Router server connection. Make sure you try a few different NordVPN servers. You can also try logging out and logging back into your account on the app. Try connecting again. If that doesn’t help, try uninstalling the app, restart your device, and then reinstall it.

If none of these solutions seem to be working, get assistance from the provider's customer service department.

FAQ

Leave a Reply

Your email address will not be published. Required fields are marked